728x90
스택 성공
시간 제한메모리 제한제출정답맞은 사람정답 비율
0.5 초 (추가 시간 없음) | 256 MB | 57572 | 22011 | 16136 | 40.290% |
문제
정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 다섯 가지이다.
- push X: 정수 X를 스택에 넣는 연산이다.
- pop: 스택에서 가장 위에 있는 정수를 빼고, 그 수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- size: 스택에 들어있는 정수의 개수를 출력한다.
- empty: 스택이 비어있으면 1, 아니면 0을 출력한다.
- top: 스택의 가장 위에 있는 정수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.
입력
첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.
출력
출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.
예제 입력 1 복사
14 push 1 push 2 top size empty pop pop pop size empty pop push 3 empty top
예제 출력 1 복사
2 2 0 2 1 -1 0 1 -1 0 3
예제 입력 2 복사
7 pop top push 123 top pop top pop
예제 출력 2 복사
-1 -1 123 123 -1 -1
출처
<개인 풀이>
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
|
#include <stdio.h>
#include <string.h>
#define MAX_SIZE 10000
void push(int* stack, int n);
int pop(int* stack);
unsigned int empty();
unsigned int size();
int stack[MAX_SIZE];
static int top = -1;
unsigned int size()
{
return top;
}
unsigned int empty()
{
if (top >= 0) return 0; //스택이 안비어있으면 0
else return 1; //스택이 비어있으면 1
}
void push(int* stack, int n)
{
stack[top] = n;
++top;
}
int pop(int* stack)
{
int pop_value;
if (empty()) //스택이 비어있는 경우
{
return -1;
}
else
{
pop_value = stack[top-1];
--top;
return pop_value; //안비어 있으면 그 수를 출력
}
}
int main(void)
{
char get_command[5];
unsigned int set_number;
int int_rotate;
scanf("%d", &int_rotate);
fgetc(stdin);
for (unsigned short i = 0; i <int_rotate; ++i) {
scanf("%s", get_command);
fgetc(stdin);
if (!strcmp(get_command,"push"))
{
scanf("%d", &set_number);
fgetc(stdin);
push(stack, set_number);
}
else if (!strcmp(get_command,"top"))
{
if (top == -1) printf("%d\n", -1);
else printf("%d\n", stack[top-1]);
}
else if (!strcmp(get_command,"size"))
{
printf("%d\n", top+1);
}
else if (!strcmp(get_command, "empty"))
{
printf("%d\n", empty());
}
else if (!strcmp(get_command, "pop"))
{
printf("%d\n", pop(stack));
}
}
return 0;
}
|
300x250
'Algorithm > 스택(Stack)구현' 카테고리의 다른 글
1874 스택수열 - C,C++14 (0) | 2020.01.14 |
---|---|
4949 균형잡힌 세상 (0) | 2020.01.09 |
10773 제로 (0) | 2020.01.08 |
9012 괄호 (0) | 2020.01.08 |
9093 단어 뒤집기 (0) | 2020.01.07 |
댓글