본문 바로가기
Algorithm/큐(Queue)구현

10845 큐

by neohtux 2020. 1. 8.
728x90

성공

 

시간 제한 메모리 제한 제출 정답 맞은 사람 정답 비율

0.5 초 (추가 시간 없음) 256 MB 33134 15363 11950 49.519%

문제

정수를 저장하는 큐를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 여섯 가지이다.

  • push X: 정수 X를 큐에 넣는 연산이다.
  • pop: 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • size: 큐에 들어있는 정수의 개수를 출력한다.
  • empty: 큐가 비어있으면 1, 아니면 0을 출력한다.
  • front: 큐의 가장 앞에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • back: 큐의 가장 뒤에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.

입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

 

예제 입력 1

15 push 1 push 2 front back size empty pop pop pop size empty pop push 3 empty front

예제 출력 1

1 2 2 0 1 2 -1 0 1 -1 0 3

 

출처

 

<개인 풀이>

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
#include<stdio.h>
#include<string.h>
 
void push(int* queue,int setnum);
int pop(int* queue);
unsigned short empty();
int front(int* queue);
int back(int* queue);
 
static int begin = 0;
static int end = 0;
 
void push(int* queueint setnum)
{
    queue[end= setnum;
    ++end;
}
int pop(int* queue)
{
    if (empty()) return -1;
    else
    {
        int result = queue[begin];
        ++begin;
        return result;
    }
}
unsigned short empty()
{
    if (begin == endreturn 1;
    else return 0;
}
int front(int* queue)
{
    if (empty()) return -1;
    else return queue[begin];
}
int back(int* queue)
{
    if (empty()) return -1;
    else return queue[end-1];
}
 
int main(void)
{
    int queue[100000];
    unsigned int getline;
    unsigned int setnumber;
    char getCom[6];
    
    scanf("%d"&getline);
    fgetc(stdin);
    for (unsigned short i = 0; i < getline; ++i)
    {
 
        scanf("%s", getCom);
        fgetc(stdin);
 
        if (!strcmp(getCom, "push"))
        {
            scanf("%d"&setnumber);
            fgetc(stdin);
            push(queue, setnumber);
        }
        else if (!strcmp(getCom, "pop"))
        {
            printf("%d\n",pop(queue));
        }
        else if (!strcmp(getCom, "size"))
        {
            printf("%d\n",(end - begin));
        }
        else if (!strcmp(getCom, "empty"))
        {
            printf("%d\n", empty());
        }
        else if (!strcmp(getCom, "front"))
        {
            printf("%d\n"front(queue));
        }
        else if (!strcmp(getCom, "back"))
        {
            printf("%d\n", back(queue));
        }
    }
 
    return 0;
}
 
 

 

300x250

댓글