728x90
https://www.acmicpc.net/problem/1697
숨바꼭질 성공
한국어
시간 제한메모리 제한제출정답맞은 사람정답 비율
2 초 | 128 MB | 67504 | 18396 | 11454 | 24.779% |
문제
수빈이는 동생과 숨바꼭질을 하고 있다. 수빈이는 현재 점 N(0 ≤ N ≤ 100,000)에 있고, 동생은 점 K(0 ≤ K ≤ 100,000)에 있다. 수빈이는 걷거나 순간이동을 할 수 있다. 만약, 수빈이의 위치가 X일 때 걷는다면 1초 후에 X-1 또는 X+1로 이동하게 된다. 순간이동을 하는 경우에는 1초 후에 2*X의 위치로 이동하게 된다.
수빈이와 동생의 위치가 주어졌을 때, 수빈이가 동생을 찾을 수 있는 가장 빠른 시간이 몇 초 후인지 구하는 프로그램을 작성하시오.
입력
첫 번째 줄에 수빈이가 있는 위치 N과 동생이 있는 위치 K가 주어진다. N과 K는 정수이다.
출력
수빈이가 동생을 찾는 가장 빠른 시간을 출력한다.
예제 입력 1 복사
5 17
예제 출력 1 복사
4
힌트
수빈이가 5-10-9-18-17 순으로 가면 4초만에 동생을 찾을 수 있다.
출처
Olympiad > USA Computing Olympiad > 2006-2007 Season > USACO US Open 2007 Contest > Silver 2번
<개인 풀이>
1. 3가지의 범위(x-1, x+1, x*2) 위치내에 만족하는 연산 값을
위치와 이동횟수 값을 queue에 저장, 방문위치를 검사한다.
2. 새 위치를 queue에서 불러와서 BFS 순회.
#include<stdio.h>
#include<queue>
unsigned int check[100001];
using namespace std;
int main(void)
{
int n, m; // n 수빈위치, m 동생 위치
int count = 0;
scanf("%d %d", &n, &m);
if (n == m)
{
printf("%d\n", 0);
return 0;
}
queue<pair<int,int>> q;
q.push(make_pair(n, count));
int location = 0;
while (!q.empty())
{
location = q.front().first;
count = q.front().second;
q.pop();
if ((location - 1) >= 0 && !check[location - 1])
{
int temp_count = count + 1;
int temp_location = location - 1;
check[temp_location] = true;
if (temp_location == m)
{
printf("%d\n",temp_count);
break;
}
q.push(make_pair(temp_location, temp_count));
}
if ((location + 1) <= 100000 && !check[location + 1])
{
int temp_count = count + 1;
int temp_location = location + 1;
check[temp_location] = true;
if (temp_location == m)
{
printf("%d\n", temp_count);
break;
}
q.push(make_pair(temp_location, temp_count));
}
if ((location * 2) <= 100000 && !check[location * 2])
{
int temp_count = count + 1;
int temp_location = location * 2;
check[temp_location] = true;
if (temp_location == m)
{
printf("%d\n", temp_count);
break;
}
q.push(make_pair(temp_location, temp_count));
}
}
return 0;
}
300x250
'Algorithm > DFS&BFS(완전탐색)' 카테고리의 다른 글
1012 유기농 배추 (0) | 2020.02.20 |
---|---|
13913 숨바꼭질4 (메모리 초과, 틀렸습니다 유의사항) (0) | 2020.02.17 |
2146 다리 만들기 (0) | 2020.02.14 |
16947 서울 지하철 2호선 (0) | 2020.02.13 |
7562 나이트의 이동 (0) | 2020.02.13 |
댓글